iFly is compatible with Prepar3D V2. Downside is that you will have to buy the full version as there is no upgrade for previous FSX owners.
Check out the post here
And you can buy it here